Easy and Simple Solution

Monday, November 21, 2016

epel-release-6-8.noarch conflicts with file from package epel-release-7-8

While installing the epel noarch on linux based system, if you get the error then you need to remove already installed latest epel noarch package.
Error:
[root@demo ~]# rpm -ivh epel-release-latest-6.noarch.rpm
warning: epel-release-latest-6.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
Preparing... ########################################### [100%]
package epel-release-7-8.noarch (which is newer than epel-release-6-8.noarch) is already installed
file /etc/yum.repos.d/epel-testing.repo from install of epel-release-6-8.noarch conflicts with file from package epel-release-7-8.noarch
file /etc/yum.repos.d/epel.repo from install of epel-release-6-8.noarch conflicts with file from package epel-release-7-8.noarch
Solution:
rpm -qa | epel-release-7-8.noarch
Remove the epel7 norch
rpm -e epel-release-7-8.noarch
Now install epel6 norch
rpm -ivh epel-release-latest-6.noarch.rpm
Real Time Analytics